The Smart & Trendy XPERIA U

The Smart & Trendy XPERIA U

Got yourself a brand new trendy XPERIA U and disappointed with the non working of the quick launch button for camera and foggy/blurred photos when using flash?

Don’t worry, we have a very simple solution for your problems.

Blurry and foggy photos when using flash in XPERIA U

Foggy photos when using flash in  XPERIA U
Foggy photos when using flash in XPERIA U

This is due to the scattering of the light form the flash, the fix for this is very simple. Just remove the protective transparent cover over the flash.

This cover is not visible usually, that’s the reason most people have problem figuring it out it’s like it doesn’t exist. You have to open the back cover to remove it.

Quick Launch Button NOT Working

Again this isn’t actually a problem or manufacturing defect, its rather a design fail. You have to press the button little harder than you normally do, it gives a small vibration when it recognizes the click.

You can configure it to capture images directly or just launch the camera in the camera settings on second page.

4 thoughts on “[Solved] XPERIA U Foggy Photos With Flash and Camera Quick Launch Problem

  • January 2, 2013 at 5:58 pm
    Permalink

    I’m having problems with removing that flash foil. I’ve scratched it all over, bu the foil won’t come of :/

    Reply
  • December 16, 2012 at 7:28 pm
    Permalink

    Wow, thank you sooooo much!
    And I was already sure my device i faulty…

    Reply
    • February 10, 2013 at 10:49 pm
      Permalink

      That was really amazing. Thanks bro.

      Reply
  • December 6, 2012 at 11:19 am
    Permalink

    solved the problem of blurry photos

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.